summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 22e30e5..55f1dde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,14 +30,15 @@ dnl AC_CONFIG_SUBDIRS([src])
dnl Checks for DEBUG option.
-AC_ARG_ENABLE([debug],
-AS_HELP_STRING([--enable-debug],
-[enable the debugging features]))
-
-if test "x$enable_debug" = "xyes"; then
- AC_DEFINE([DEBUG], [], [Define if one wants to debug the program.])
- dnl AC_CHECK_FUNCS([clock_gettime])
-fi
+dnl This is bad practice. Use the script configure.debug instead.
+dnl AC_ARG_ENABLE([debug],
+dnl AS_HELP_STRING([--enable-debug],
+dnl [enable the debugging features]))
+
+dnl if test "x$enable_debug" = "xyes"; then
+dnl AC_DEFINE([DEBUG], [], [Define if one wants to debug the program.])
+dnl dnl AC_CHECK_FUNCS([clock_gettime])
+dnl fi
AC_CONFIG_FILES([Makefile src/Makefile])