summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2022-02-06 18:11:03 +0800
committerJSDurand <mmemmew@gmail.com>2022-02-06 18:11:03 +0800
commit3d709982b66314b23b5957041580dd4918561a53 (patch)
tree1c23bbd7695499e1d74ce2c35ce27f6851a7f642 /configure.ac
parent1c8cbfd09ff9dd02f6d8d938c45e3f29a35f6f32 (diff)
Add a script to build for debugging purposes
I think this is a better practice than the previously used hard-coded configure option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 22e30e5..55f1dde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,14 +30,15 @@ dnl AC_CONFIG_SUBDIRS([src])
dnl Checks for DEBUG option.
-AC_ARG_ENABLE([debug],
-AS_HELP_STRING([--enable-debug],
-[enable the debugging features]))
-
-if test "x$enable_debug" = "xyes"; then
- AC_DEFINE([DEBUG], [], [Define if one wants to debug the program.])
- dnl AC_CHECK_FUNCS([clock_gettime])
-fi
+dnl This is bad practice. Use the script configure.debug instead.
+dnl AC_ARG_ENABLE([debug],
+dnl AS_HELP_STRING([--enable-debug],
+dnl [enable the debugging features]))
+
+dnl if test "x$enable_debug" = "xyes"; then
+dnl AC_DEFINE([DEBUG], [], [Define if one wants to debug the program.])
+dnl dnl AC_CHECK_FUNCS([clock_gettime])
+dnl fi
AC_CONFIG_FILES([Makefile src/Makefile])