summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..fbf987e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,28 @@
+AC_PREREQ([2.60])
+
+AC_INIT([REP], m4_esyscmd([./find-version.sh]), [durand@jsdurand.xyz])
+
+dnl patsubst(m4_esyscmd([./find-version.sh]), ` "')
+
+AC_COPYRIGHT([This package is covered by GPL v3.])
+
+AC_CONFIG_AUX_DIR([build-aux])
+
+AM_INIT_AUTOMAKE([subdir-objects])
+
+AM_SILENT_RULES([yes])
+
+dnl AC_CONFIG_SUBDIRS([graph], [receme], [nfa], [repcore])
+dnl AC_CONFIG_SUBDIRS([graph])
+
+AC_PATH_PROG([CARGO], [cargo], [notfound])
+AS_IF([test "$CARGO" = "notfound"], [AC_MSG_ERROR([cargo is required])])
+
+AC_PATH_PROG([RUSTC], [rustc], [notfound])
+AS_IF([test "$RUSTC" = "notfound"], [AC_MSG_ERROR([rustc is required])])
+
+AC_CONFIG_FILES([Makefile graph/Makefile])
+
+AC_OUTPUT
+
+