summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-07-22 11:37:54 +0800
committerJSDurand <mmemmew@gmail.com>2023-07-22 11:37:54 +0800
commit9d80a43a469dd474691c95e9899db09449076df7 (patch)
treeeb61f44c3b5aff9b53071ff55fd061a8c413d537 /src/Makefile.am
parentca1a2fa607a3ce95d8cf68f1a7a481d62b0ecf72 (diff)
Add some auxiliary data.
Try to fix some minor issues.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..114b168
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,20 @@
+CC=gcc
+
+CFLAGS=-g -O0
+
+rep.so: binding.c ../target/debug/librep.dylib helper.o big_endian.o
+ $(CC) $(CFLAGS) $+ -shared -export-dynamic -o $@
+
+test: test.c ../target/debug/librep.dylib helper.o big_endian.o
+ $(CC) $(CFLAGS) $+ -o $@
+
+.PHONY: clean rs windows
+
+clean:
+ rm *.o
+
+rs:
+ cargo build
+
+windows:
+ cargo build --target=x86_64-pc-windows-gnu