summaryrefslogtreecommitdiff
path: root/semiring/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-02-27 12:36:41 +0800
committerJSDurand <mmemmew@gmail.com>2023-02-27 12:36:41 +0800
commitfbaa420ed550e9c3e7cdc09d4a8ec22bfbd782a6 (patch)
treefad9722825bb3fa796dd52c3fd4a8bf46b958cf9 /semiring/Cargo.toml
parentafad02bdff111ecccb0077b9c989e869723c231c (diff)
before a major refactor
I decide to adopt a new approach of recording and updating item derivation forests. Since this affects a lot of things, I decide to commit before the refactor, so that I can create a branch for that refactor.
Diffstat (limited to 'semiring/Cargo.toml')
-rw-r--r--semiring/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/semiring/Cargo.toml b/semiring/Cargo.toml
index 0a82e32..caf6cb0 100644
--- a/semiring/Cargo.toml
+++ b/semiring/Cargo.toml
@@ -6,3 +6,8 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+grammar = { path = "../grammar" }
+
+[dev-dependencies]
+grammar = { path = "../grammar", features = ["test-helper"] }
+