summaryrefslogtreecommitdiff
path: root/graph_macro/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-01-13 14:25:40 +0800
committerJSDurand <mmemmew@gmail.com>2023-01-13 14:25:40 +0800
commit3c6511f69c7639abff60ac9999a08ce2daa24a7d (patch)
treeb39aa27a4c5454a4b0203faccd57e4136dbbe663 /graph_macro/Cargo.toml
parent1a3d346f413325ed37848a6b2526e8e729269833 (diff)
macro: try to write a macro for inhereting graphs
An attempt to write a derive macro to automatically derive the various graph traits.
Diffstat (limited to 'graph_macro/Cargo.toml')
-rw-r--r--graph_macro/Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/graph_macro/Cargo.toml b/graph_macro/Cargo.toml
new file mode 100644
index 0000000..1e4c4db
--- /dev/null
+++ b/graph_macro/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "graph_macro"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[lib]
+proc-macro = true
+
+[dependencies]