summaryrefslogtreecommitdiff
path: root/graph/Makefile.am
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2022-11-15 12:01:28 +0800
committerJSDurand <mmemmew@gmail.com>2022-11-15 12:01:28 +0800
commitcb7bcfad4ab0041aaf3fde3185e27ee46bb37788 (patch)
treea4fd99b138b72617b6c4c2b04f5d2655d0fedcc5 /graph/Makefile.am
Initial commit
Basic GNU standard files are added, and we now stop worrying about monadic anamorphisms. The current focus is on testing the correctness of the algorithm, so I need convenient support for manipulating, interpreting, examining, and per chance animating nondeterministic automata.
Diffstat (limited to 'graph/Makefile.am')
-rw-r--r--graph/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/graph/Makefile.am b/graph/Makefile.am
new file mode 100644
index 0000000..776b911
--- /dev/null
+++ b/graph/Makefile.am
@@ -0,0 +1,12 @@
+.PHONY: dev rel
+
+all: dev
+
+dev:
+ @CARGO@ build
+
+rel:
+ @CARGO@ build --release
+
+clean:
+ @CARGO@ clean