summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ffb9a5c..5eff3c5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,10 @@
AM_CFLAGS = -Wall -Wextra
noinst_LIBRARIES = libeps.a
-libeps_a_SOURCES = grammar.c list.c reader.c \
-grammar.h list.h util.h reader.h
+libeps_a_SOURCES = grammar.c list.c util.c reader.c \
+str.c utf8.c \
+grammar.h list.h util.h reader.h \
+str_partial.h str.h utf8.h
libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
@@ -23,9 +25,11 @@ check_PROGRAMS = check_list check_grammar check_reader
check_list_SOURCES = test/check_list.c list.c
-check_grammar_SOURCES = test/check_grammar.c list.c grammar.c
+check_grammar_SOURCES = test/check_grammar.c list.c grammar.c str.c \
+utf8.c
-check_reader_SOURCES = test/check_reader.c list.c grammar.c reader.c
+check_reader_SOURCES = test/check_reader.c list.c grammar.c reader.c \
+str.c utf8.c util.c
TESTS = $(check_PROGRAMS)