summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a708ba4..fe8be18 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,10 @@
AM_CFLAGS = -Wall -Wextra
noinst_LIBRARIES = libeps.a
-libeps_a_SOURCES = grammar.c list.c util.c reader.c \
-str.c utf8.c dfa.c ht.c \
-grammar.h list.h util.h reader.h \
-str_partial.h str.h utf8.h dfa.h ht.h
+libeps_a_SOURCES = grammar.c list.c util.c reader.c str.c \
+utf8.c dfa.c ht.c slr_table.c grammar.h \
+list.h util.h reader.h str_partial.h \
+str.h utf8.h dfa.h ht.h slr_table.h
libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
@@ -26,11 +26,11 @@ check_ht
check_list_SOURCES = test/check_list.c list.c
-check_grammar_SOURCES = test/check_grammar.c list.c grammar.c str.c \
-utf8.c
+check_grammar_SOURCES = test/check_grammar.c list.c ht.c grammar.c \
+utf8.c str.c
check_reader_SOURCES = test/check_reader.c list.c grammar.c reader.c \
-str.c utf8.c util.c
+str.c utf8.c util.c ht.c
check_dfa_SOURCES = test/check_dfa.c dfa.c list.c str.c utf8.c