summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9a97792
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,44 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.70])
+
+AC_INIT([eps], [0.1.0], [mmemmew@gmail.com], [], [])
+
+AC_COPYRIGHT([This package is covered by GPL v3.])
+
+AM_PROG_AR
+
+dnl Check for RANLIB
+AC_PROG_RANLIB
+
+AC_CONFIG_SRCDIR([src/grammar.h])
+
+AC_CONFIG_HEADERS([src/config.h])
+
+AC_CONFIG_AUX_DIR([build-aux])
+
+AM_INIT_AUTOMAKE([-Wall -Werror subdir-objects])
+
+AM_SILENT_RULES([yes])
+
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Subdirectory
+
+dnl AC_CONFIG_SUBDIRS([src])
+
+dnl Checks for DEBUG option.
+
+AC_ARG_ENABLE([debug],
+AS_HELP_STRING([--enable-debug],
+[enable the debugging features]))
+
+if test "x$enable_debug" = "xyes"; then
+ AC_DEFINE([DEBUG], [], [Define if one wants to debug the program.])
+ dnl AC_CHECK_FUNCS([clock_gettime])
+fi
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+
+AC_OUTPUT