summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2021-11-08 16:37:57 +0800
committerJSDurand <mmemmew@gmail.com>2021-11-08 16:37:57 +0800
commit9594210f02572681ed581c5197ace4c207db0917 (patch)
tree08bf1bf079d111c64cf3128dd68323abdce78228 /src/Makefile.am
initial commit
Now the rough framework is established and the grammar class is sort of ready. It remains to write a general input reading mechanism.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d38ef1b
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,32 @@
+AM_CFLAGS = -Wall -Wextra
+
+noinst_LIBRARIES = libeps.a
+libeps_a_SOURCES = grammar.c list.c input.c \
+grammar.h list.h util.h input.h
+
+libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
+
+# Make TAGS automatically
+
+all-local: MYTAGS
+
+MYTAGS: $(TAGS_DEPENDENCIES) $(am__tagged_files)
+ @if $(AM_V_P); then $(MAKE) TAGS; else echo "MAKE TAGS"; \
+ $(MAKE) TAGS > /dev/null; fi;
+
+
+CLEANFILES = TAGS
+
+# tests
+
+check_PROGRAMS = check_list check_grammar
+
+check_list_SOURCES = test/check_list.c list.c
+
+check_grammar_SOURCES = test/check_grammar.c list.c grammar.c
+
+TESTS = $(check_PROGRAMS)
+
+AM_COLOR_TESTS = always
+
+