summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2022-01-11 09:58:43 +0800
committerJSDurand <mmemmew@gmail.com>2022-01-11 09:58:43 +0800
commit91016bd3855375796fd1eabd501ebc12491f2655 (patch)
treec4a608966b686c9639a90b92c31c00632532fac8 /src/Makefile.am
parent949888ad5d0cd0f9f9a87f9938a632b3e32df051 (diff)
Add the framework for character classes.
Now we have the potential to recognize character classes. But the most important task for us now is to experiment with ((B)RN)GLR algorithms, so we leave the character classes at the present state for a moment.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4690876..f43fbee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,9 +2,9 @@ AM_CFLAGS = -Wall -Wextra
noinst_LIBRARIES = libeps.a
libeps_a_SOURCES = grammar.c list.c util.c reader.c \
-str.c utf8.c lr_table.c \
+str.c utf8.c dfa.c \
grammar.h list.h util.h reader.h \
-str_partial.h str.h utf8.h lr_table.h
+str_partial.h str.h utf8.h dfa.h
libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
@@ -21,7 +21,7 @@ CLEANFILES = TAGS
# tests
-check_PROGRAMS = check_list check_grammar check_reader
+check_PROGRAMS = check_list check_grammar check_reader check_dfa
check_list_SOURCES = test/check_list.c list.c
@@ -31,6 +31,8 @@ utf8.c
check_reader_SOURCES = test/check_reader.c list.c grammar.c reader.c \
str.c utf8.c util.c
+check_dfa_SOURCES = test/check_dfa.c dfa.c list.c str.c utf8.c
+
TESTS = $(check_PROGRAMS)
AM_COLOR_TESTS = always