summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2022-02-01 12:22:34 +0800
committerJSDurand <mmemmew@gmail.com>2022-02-01 12:22:34 +0800
commit3fb5430080199a6d92a63f8259fe4a88df9b83ba (patch)
tree767c3266b59566e98234ec81b228cf8115096939 /src/Makefile.am
parenteb007d554251456a2a508849edf91b15aab1333e (diff)
need to stop abusing hash tables
Hash tables take too much space! If I use hash tables, the length of the input will be severely limited, to an unacceptable extent. So we have to use arrays instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 446961d..b897ec0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,29 +22,32 @@ CLEANFILES = TAGS
# tests
check_PROGRAMS = check_list check_grammar check_reader check_dfa \
-check_ht check_bsr check_crf check_cnp
+check_ht check_bsr check_crf check_cnp check_pred
check_list_SOURCES = test/check_list.c list.c
check_grammar_SOURCES = test/check_grammar.c list.c ht.c grammar.c \
-utf8.c str.c
+utf8.c str.c dfa.c
check_reader_SOURCES = test/check_reader.c list.c grammar.c reader.c \
-str.c utf8.c util.c ht.c
+str.c utf8.c util.c ht.c dfa.c
check_dfa_SOURCES = test/check_dfa.c dfa.c list.c str.c utf8.c
check_ht_SOURCES = test/check_ht.c ht.c
check_bsr_SOURCES = test/check_bsr.c bsr.c grammar.c list.c util.c \
-ht.c utf8.c str.c
+ht.c utf8.c str.c dfa.c
check_crf_SOURCES = test/check_crf.c crf.c grammar.c list.c util.c \
-ht.c utf8.c str.c
+ht.c utf8.c str.c dfa.c
check_cnp_SOURCES = test/check_cnp.c crf.c cnp.c grammar.c list.c \
util.c ht.c utf8.c str.c dfa.c bsr.c
+check_pred_SOURCES = test/check_pred.c dfa.c list.c str.c utf8.c \
+grammar.c util.c ht.c
+
TESTS = $(check_PROGRAMS)
AM_COLOR_TESTS = always