summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-12-06 03:44:28 +0800
committerJSDurand <mmemmew@gmail.com>2023-12-06 03:44:28 +0800
commit5d7ae639739e1b5389bc94c227aeb6661cb8eab1 (patch)
treecdc6dd227e2e76ca4790232159c94a23c53f550c /Cargo.toml
initial commit
A manual implementation of the Berlekamp algorithm for finding irreducible factors of polynomials over finite fields.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d1c48a3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "berlekamp"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+num = "0.4.1" \ No newline at end of file