summaryrefslogtreecommitdiff
path: root/grammar/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'grammar/Cargo.toml')
-rw-r--r--grammar/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/grammar/Cargo.toml b/grammar/Cargo.toml
new file mode 100644
index 0000000..20c4b48
--- /dev/null
+++ b/grammar/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "grammar"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[features]
+default = []
+
+# This flag exposes the module "test_grammar_helper" which provides
+# some grammars for testing.
+test-helper = []
+
+[dependencies]
+nfa = { path = "../nfa" }
+graph = { path = "../graph" }
+
+[dev-dependencies]
+grammar = { path = ".", features = ["test-helper"] }