summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e672e74
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "rep"
+version = "0.1.0"
+edition = "2021"
+authors = ["JSDurand <durand@jsdurand.xyz>"]
+description = "Rust, Emacs, and Parsers"
+license = "GPL-3.0-or-later"
+keywords = ["emacs", "parser"]
+# We require a minimal Rust version of 1.65 as we need the feature of
+# generic associated types, which are not stablized until version
+# 1.65.
+rust-version = "1.65"
+# testing the new resolver, even though this has no dependencies ;p
+
+[workspace]
+members = ["graph", "receme", "nfa", "repcore"]
+resolver = "2"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+receme = { path = "receme" }
+
+[dev-dependencies]
+criterion = "0.4"
+
+[features]
+default = []
+tokenizer = []
+
+[profile.bench]
+debug = true
+
+[[bench]]
+name = "bench_receme"
+harness = false