summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1ddd0a0..a1409fa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,9 +18,15 @@ members = [ "graph", "receme", "nfa", "chain", "viz", "grammar",
# testing the new resolver, even though this has no dependencies ;p
resolver = "2"
+[lib]
+crate-type = ["cdylib"]
+
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+chain = { path = "./chain" }
+grammar = { path = "./grammar" }
+graph = { path = "./graph" }
[features]
default = []