summaryrefslogtreecommitdiff
path: root/nfa/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-02-27 12:36:41 +0800
committerJSDurand <mmemmew@gmail.com>2023-02-27 12:36:41 +0800
commitfbaa420ed550e9c3e7cdc09d4a8ec22bfbd782a6 (patch)
treefad9722825bb3fa796dd52c3fd4a8bf46b958cf9 /nfa/Cargo.toml
parentafad02bdff111ecccb0077b9c989e869723c231c (diff)
before a major refactor
I decide to adopt a new approach of recording and updating item derivation forests. Since this affects a lot of things, I decide to commit before the refactor, so that I can create a branch for that refactor.
Diffstat (limited to 'nfa/Cargo.toml')
-rw-r--r--nfa/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/nfa/Cargo.toml b/nfa/Cargo.toml
index 7f48760..9eac932 100644
--- a/nfa/Cargo.toml
+++ b/nfa/Cargo.toml
@@ -7,8 +7,9 @@ edition = "2021"
[dependencies]
graph = { path = "../graph", optional = true }
-receme = { path = "../receme" }
+receme = { path = "../receme", optional = true }
[features]
default = ["default-graph"]
default-graph = ["dep:graph"]
+recursion = ["dep:receme"]