summaryrefslogtreecommitdiff
path: root/nfa/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-06-02 15:00:48 +0800
committerJSDurand <mmemmew@gmail.com>2023-06-02 15:00:48 +0800
commit8486474f377faf2d800d79166a7abe6b975e3e50 (patch)
treef06baa22bafebf9393869664067e9cf308c92634 /nfa/Cargo.toml
parent1455da10f943e2aa1bdf26fb2697dafccc61e073 (diff)
Fix a bug of duplication from planting after sploing
I should have staged and committed these changes separately, but I am too lazy to deal with that. The main changes in this commit are that I added the derive macro that automates the delegation of the Graph trait. This saves a lot of boiler-plate codes. The second main change, perhaps the most important one, is that I found and tried to fix a bug that caused duplication of nodes. The bug arises from splitting or cloning a node multiple times, and immediately planting the same fragment under the new "sploned" node. That is, when we try to splone the node again, we found that we need to splone, because the node that was created by the same sploning process now has a different label because of the planting of the fragment. Then after the sploning, we plant the fragment again. This makes the newly sploned node have the same label (except for the clone index) and the same children as the node that was sploned and planted in the previous rounds. The fix is to check for the existence of a node that has the same set of children as the about-to-be-sploned node, except for the last one, which contains the about-to-be-planted fragment as a prefix. If that is the case, treat it as an already existing node, so that we do not have to splone the node again. This is consistent with the principle to not create what we do not need.
Diffstat (limited to 'nfa/Cargo.toml')
-rw-r--r--nfa/Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/nfa/Cargo.toml b/nfa/Cargo.toml
index 9eac932..75a6a43 100644
--- a/nfa/Cargo.toml
+++ b/nfa/Cargo.toml
@@ -6,10 +6,9 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-graph = { path = "../graph", optional = true }
+graph = { path = "../graph" }
+graph_macro = { path = "../graph_macro" }
receme = { path = "../receme", optional = true }
[features]
-default = ["default-graph"]
-default-graph = ["dep:graph"]
recursion = ["dep:receme"]