summaryrefslogtreecommitdiff
path: root/graph_macro/Cargo.toml
diff options
context:
space:
mode:
authorJSDurand <mmemmew@gmail.com>2023-05-04 13:02:39 +0800
committerJSDurand <mmemmew@gmail.com>2023-05-04 13:02:39 +0800
commit662817e6367a865a2d86a99581172cc45f585807 (patch)
treee5c7d1a0a52ce9d057d9c27ac4c7549b77198efb /graph_macro/Cargo.toml
parent57d600f261cca5d9076239e548c6e00646f774b6 (diff)
Completed the procedural macro for deriving Graphs.
The macro `graph_derive` can automatically write the boiler-plate codes for wrapper types one of whose sub-fields implements the `Graph` trait. The generated implementation will delegate the `Graph` operations to the sub-field which implements the `Graph` trait. I plan to add more macros, corresponding to various other graph-related traits, so that no such boiler-plate codes are needed, at least for my use-cases.
Diffstat (limited to 'graph_macro/Cargo.toml')
-rw-r--r--graph_macro/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/graph_macro/Cargo.toml b/graph_macro/Cargo.toml
index 1e4c4db..6e96140 100644
--- a/graph_macro/Cargo.toml
+++ b/graph_macro/Cargo.toml
@@ -9,3 +9,4 @@ edition = "2021"
proc-macro = true
[dependencies]
+graph = { path = "../graph" } \ No newline at end of file