summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fe8be18..e4eae9e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,9 +2,9 @@ AM_CFLAGS = -Wall -Wextra
noinst_LIBRARIES = libeps.a
libeps_a_SOURCES = grammar.c list.c util.c reader.c str.c \
-utf8.c dfa.c ht.c slr_table.c grammar.h \
-list.h util.h reader.h str_partial.h \
-str.h utf8.h dfa.h ht.h slr_table.h
+utf8.c dfa.c ht.c bsr.c cnp.c \
+grammar.h list.h util.h reader.h str_partial.h \
+str.h utf8.h dfa.h ht.h bsr.h cnp.h
libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
@@ -22,7 +22,7 @@ CLEANFILES = TAGS
# tests
check_PROGRAMS = check_list check_grammar check_reader check_dfa \
-check_ht
+check_ht check_bsr check_cnp
check_list_SOURCES = test/check_list.c list.c
@@ -36,6 +36,12 @@ check_dfa_SOURCES = test/check_dfa.c dfa.c list.c str.c utf8.c
check_ht_SOURCES = test/check_ht.c ht.c
+check_bsr_SOURCES = test/check_bsr.c bsr.c grammar.c list.c util.c \
+ht.c utf8.c str.c
+
+check_cnp_SOURCES = test/check_cnp.c cnp.c grammar.c list.c util.c \
+ht.c utf8.c str.c
+
TESTS = $(check_PROGRAMS)
AM_COLOR_TESTS = always