summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f43fbee..a708ba4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,9 +2,9 @@ AM_CFLAGS = -Wall -Wextra
noinst_LIBRARIES = libeps.a
libeps_a_SOURCES = grammar.c list.c util.c reader.c \
-str.c utf8.c dfa.c \
+str.c utf8.c dfa.c ht.c \
grammar.h list.h util.h reader.h \
-str_partial.h str.h utf8.h dfa.h
+str_partial.h str.h utf8.h dfa.h ht.h
libeps_a_CFLAGS = $(AM_CFLAGS) --pedantic
@@ -21,7 +21,8 @@ CLEANFILES = TAGS
# tests
-check_PROGRAMS = check_list check_grammar check_reader check_dfa
+check_PROGRAMS = check_list check_grammar check_reader check_dfa \
+check_ht
check_list_SOURCES = test/check_list.c list.c
@@ -33,6 +34,8 @@ str.c utf8.c util.c
check_dfa_SOURCES = test/check_dfa.c dfa.c list.c str.c utf8.c
+check_ht_SOURCES = test/check_ht.c ht.c
+
TESTS = $(check_PROGRAMS)
AM_COLOR_TESTS = always